Vorlage Diskussion:Poi

Aus Wikivoyage
Zur Navigation springen Zur Suche springen

Druckaufbereitung[Bearbeiten]

Ich habe die Vorlage in die [[Kategorie:Vom Druck ausschließen|{{PAGENAME}}]] eingetragen. Aber trotzdem werden alle Parameter ausgegeben, wenn man einen Artikel druckt. Die farbige Markerzahl soll natürlich erscheinen, aber alles andere nicht. Kann jemand helfen? -- Joachim Mey2008 (Diskussion) 15:53, 22. Apr. 2013 (CEST)

Typ Biergarten in der vCard[Bearbeiten]

Derzeit erhält der Typ "Beergarden" in der vCard die automatische Kennfarbe schwarz zugeordnet. Soweit ich das sehe, wird schwarz ansonsten für die automatisierten Typen des "Nachtleben"s verwendet.

Aus meiner Sicht gehören Biergärten zum ganztägigen Typ Essen und Trinken / Restaurant und nicht zum Nachtleben: In den Biergarten geht man im Sommer am späten Nachmittag zum Essen und Trinken und zur Unterhaltung, bei passender Gelegenheit und am Wochenende oft auch schon Mittags, manchmal auch am Vormittag. Es kann durchaus sein, dass man bis in den späten Abend und bis in die Nacht da sitzen bleibt, aber das ist nicht zwangsläufig.

Sinnvoll ist für Biergärten das automatisierte Symbol wie für "Essen und Trinken" / Restaurant.--Bbb (Diskussion) 09:23, 19. Dez. 2013 (CET)

Parameter "Farbe oder Art" im Vorlagenmeister[Bearbeiten]

Bei der Nutzung des Vorlagenmeisters wird ein Leerzeichen hinter den Parametern eingefügt. Beispiel: aus |see| wird |see |. Bei erneutem Aufruf des Vorlagenmeisters für diesen POI wird dann der Parameter "Farbe oder Art" nicht mehr erkannt und immer "black" angezeigt. -- Mey2008 (Diskussion) 06:30, 10. Dez. 2014 (CET)

Habe den Fehler unter w:Wikipedia Diskussion:Technik/Skin/Gadgets/Vorlagenmeister gemeldet. -- FriedhelmW (Diskussion) 09:09, 10. Dez. 2014 (CET)
Eine neue Version des Vorlagenmeisters steht zum Testen bereit. Details unter obigem Link. -- FriedhelmW (Diskussion) 19:14, 5. Jan. 2015 (CET)

Poi Typ Black[Bearbeiten]

Moin, mir ist neulich aufgefallen, dass bei schwarzen Poi's 1 Typ ist Farbbezeichnung statt einem schwarzen Quadrat jetzt ein "Weinglas" erscheint. Bleibt diese Änderung dauerhaft? Schönen Abend -- Feuermond16 (Diskussion) 18:20, 18. Dez. 2014 (CET)

Nicht nur bei black, auch bei den Farben chocolate 1 Typ ist Farbbezeichnung oder brown 1 Typ ist Farbbezeichnung werden Symbole angezeigt, statt den reinen Farben. Diese Zuordung ist eigentlich nicht nötig , da es die doch über andere Begriffe schon gibt. --Bernello (Diskussion) 20:17, 18. Dez. 2014 (CET)
@Bernello: Stimmt, aber das ist schon seit längerem so. @Mey2008: Ich glaube, du bist wahrscheinlich der einzige, der des Rätsels Lösung kennt. -- Feuermond16 (Diskussion) 21:52, 18. Dez. 2014 (CET)
Seit Einführung der Vorlage VCard/Type2PoiType im September 2013 werden die in der Tabelle der Vorlagenbeschreibung aufgeführten Farben durch das Symbol für den entsprechenden POI-Typ in der Karte dargestellt. Das wurde notwendig, da in der Vergangenheit in der Vorlage Poi oft die Farbe, also z.B. 'black' statt 'drink' (für eine Bar usw.) eingetragen wurde. Eine gesonderte Darstellung für type=farbe als Farbquadrat wäre möglich, würde aber Auswirkungen auf ältere Eintragungen haben, die dann überarbeitet werden müssten. -- Joachim Mey2008 (Diskussion) 07:18, 19. Dez. 2014 (CET)
Dann werde ich wohl in den Artikeln, wo ich vor kurzem noch die Poi-Farbe black hinterlegt habe, mir eine andere Farbe ausdenken. Ist aber kein Problem, bzw. außer black, chocolate und brown kann ich doch alle beruhigt benutzen, oder? Viele Grüße -- Feuermond16 (Diskussion) 12:09, 19. Dez. 2014 (CET)
Nur die Farben blue, gold, lime, maroon, mediumaqumarine, red und silver werden in der deutschen Sprachversion nicht in Symbole umsetzt und können frei verwendet werden. Der Vorlagenmeister für die Vorlage Poi müsste noch entsprechend angepasst werden. -- Joachim Mey2008 (Diskussion) 14:55, 19. Dez. 2014 (CET)

Darstellung der automatisch nummerierten POIs[Bearbeiten]

Bei mir werden die automatisch nummerierten POIs mit einem angefügten Quadrat dargestellt, also:  1‪‪‪Ỻ  und  1‪‪‪Ỻ . Womöglich ist dies Browser-abhängig (hier: Opera) oder abhängig vom implementierten Zeichensatz. Dennoch wäre es gut, wenn die Darstellung von solchen Maßgaben unabhängig ist. Denn die fest nummerierten POIs funktionieren. Kennt jemand die "tiefer liegende" Ursache und kann diese beheben? -- theway (Diskussion) 15:35, 19. Feb. 2015 (CET)

Ich kann das Problem mit Opera 27.0 unter Windows nicht nachvollziehen. Kannst du etwas genauer werden? -- FriedhelmW (Diskussion) 15:57, 19. Feb. 2015 (CET)
Es könnte nur mit Uraltbrowsern Probleme geben, weil wir für das nachträgliche Einfügen der Zahlen Counter und das css-Statement ::before verwenden. Das beherrscht aber schon IE8 auf Windows XP, ein Browser, der eigentlich für alle möglichen Probleme bekannt ist. --RolandUnger (Diskussion) 06:48, 20. Feb. 2015 (CET)

Problem (nicht an der Wurzel) behoben[Bearbeiten]

So weit wie ich hier recherchieren kann, ist um die Nummerierung überhaupt erzeugen zu können, bei Wikivoyge ein kleines Hilfsmittelchen erforderlich, nämlich ein Dummy-Nulllängen-Leer-Zeichen ​. Genauso gut könnte es ein Punkt, Strich, Buchstabe oder sonst was sein, was jedoch in jedem POI-Kasten stören würde. Nur leider, dieses Zeichen mit der laufenden Nummer 8203 ist nicht in jedem Zeichensatz implementiert. So zum Beispiel nicht in Arial Version 3 aus dem Jahre 2008 (359 kByte).

Um diesen Effekt in Wikivoyage halbwegs zu beheben, könnte anstelle ​ z. B.   verwendet werden. Interessanter Weise scheint nämlich der Browser dieses Kurz-Leerzeichen in irgendeinem Ersatz-Zeichensatz zu finden. Dies Zeichen ist ebenfalls unsichtbar. Dem aufmerksamen Beobachter fällt jedoch der leicht verlängerte POI-Kasten auf.

Die wirkliche Ursache vermute ich liegt darin, dass ohne diesem &#x200B; - Dummy der HTML-Code für die Autonummerierung <span class="poi_autonum" ...> schlichtweg nicht eingefügt wird. In diese noch tieferen Wikivoyage Programmier-Untergründe vermag ich jetzt nun doch nicht eindringen.

Alternativ können die Auswirkungen der Dummy-Notlösung vermieden werden, indem auf dem Rechner ein Zeichensatz mit einem implementierten &#x200B; - Zeichen verwendet wird. Entweder es wird z. B. in Opera wird für die Option "Schriftfamilie Sans Serif" die Schrift "Arial Unicode" (mit dennoch anderen Schriftgrößen) eingestellt oder besser, es wird eine aktualisierte arial.ttf (z.B. Version 5.06, 2010, 755 kByte) installiert. --theway (Diskussion) 22:19, 23. Feb. 2015 (CET)

Bei Uraltsystemen gibt es immer mal den Effekt, dass nicht jedes Unicode-Zeichen dargestellt werden kann und Kästchen eingefügt werden. Zumindest gibt es bereits keine Probleme mit Opera 12.17, Win32, Windows XP + Office 2000. Auch ist &#x200B; schon vor ewigen Zeiten im Unicode definiert worden. In allen modernen Systemen ist mindestens ein Zeichensatz enthalten, der den Großteil der Unicode-Zeichen abdeckt, unter Windows ist dies Arial Unicode MS. Der Zeichensatz stammt aus dem Jahr 2000 (!) oder früher; und macht braucht ihn ohnehin auch für andere UTF-Zeichen.
Es muss ein Zeichen in die Box, damit sie überhaupt dargestellt wird, denn sie wäre bei der automatischen Nummerierung leer und würde nicht dargestellt werden. Es ist leider nicht mehr möglich, alle Uralt-Systeme zu unterstützen, und bei XP ist der Support ja schon seit zwei Jahren ausgelaufen. Für die weitere Entwicklung will ich sogar in eine andere Richtung gehen: ich denke, dass es machbar sein sollte, anstelle der Kästchen mit der Hintergrundfarbe, die ja meist im Druck fehlt, das Symbol zu wählen, das auch in der Karte erscheint. Da muss ich aber noch etwas basteln. Dann würden sich aber mehrere Probleme auf einmal lösen lassen. --RolandUnger (Diskussion) 09:00, 24. Feb. 2015 (CET)
So wie ich das lese, hast Du hier wesentliche Teile mitentwickelt. Große Anerkennung meinerseits! Das System, bei welchem der Effekt auftrat war Windows XP + Office 2000 + Opera 11.64. Aber wie gesagt, dort ist alles behoben. --theway (Diskussion) 12:56, 6. Mär. 2015 (CET)

Layer[Bearbeiten]

Da der Layer M zur Zeit nicht funktioniert wird bis auf weiteres Layer O als default verwendet. -- FriedhelmW (Diskussion) 22:52, 19. Dez. 2015 (CET)